1、Local preference选路解析
成都创新互联公司成立以来不断整合自身及行业资源、不断突破观念以使企业策略得到完善和成熟,建立了一套“以技术为基点,以客户需求中心、市场为导向”的快速反应体系。对公司的主营项目,如中高端企业网站企划 / 设计、行业 / 企业门户设计推广、行业门户平台运营、成都App定制开发、手机网站开发、微信网站制作、软件开发、眉山联通机房等实行标准化操作,让客户可以直观的预知到从成都创新互联公司可以获得的服务效果。
属性 | 传播范围 | 默认值 | 优先值 | 方向 | 备注 |
weight | 本路由器 | 本路由器32768,其他路由器0 | 大值优先 | IN | CISCO私有 |
Local preference | AS内部 | 100:边界路由器,通告给IBGP邻居,告知如何离开本AS | 大值优先 | OUT |
修改Local preference值的方法:
方法一:全部修改通告给IBGP邻居的路由的Local preference值,例如:
router bgp 4
bgp default local-preference 125
方法二:部分修改通告给IBGP邻居的路由的Local preference值,例如:
2、实验拓扑
3、基础配置
R1配置
interface Loopback0
ip address 1.1.1.1 255.255.255.0
interface Serial0/0
ip address 13.1.1.1 255.255.255.0
interface Serial0/1
ip address 14.1.1.1 255.255.255.0
router ospf 110
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 14.1.1.0 0.0.0.255 area 0
router bgp 4
no synchronization
bgp router-id 1.1.1.1
neighbor 4.4.4.4 remote-as 4
neighbor 4.4.4.4 update-source Loopback0
neighbor 4.4.4.4 next-hop-self
neighbor 13.1.1.3 remote-as 3
no auto-summary
R2配置
interface Loopback0
ip address 2.2.2.2 255.255.255.0
interface Serial0/1
ip address 23.1.1.2 255.255.255.0
interface FastEthernet1/0
ip address 24.1.1.2 255.255.255.0
router ospf 110
router-id 2.2.2.2
network 2.2.2.0 0.0.0.255 area 0
network 24.1.1.0 0.0.0.255 area 0
router bgp 4
no synchronization
bgp router-id 2.2.2.2
neighbor 4.4.4.4 remote-as 4
neighbor 4.4.4.4 update-source Loopback0
neighbor 4.4.4.4 next-hop-self
neighbor 23.1.1.3 remote-as 3
no auto-summary
R3配置
interface Loopback0
ip address 3.3.3.3 255.255.255.0
interface Loopback1
ip address 33.33.33.33 255.255.255.0
interface Serial0/0
ip address 13.1.1.3 255.255.255.0
interface Serial0/1
ip address 23.1.1.3 255.255.255.0router bgp 3
no synchronization
bgp router-id 3.3.3.3
network 3.3.3.0 mask 255.255.255.0
network 33.33.33.0 mask 255.255.255.0
neighbor 13.1.1.1 remote-as 4
neighbor 23.1.1.2 remote-as 4
no auto-summary
R4配置
interface Loopback0
ip address 4.4.4.4 255.255.255.0
interface Serial0/1
ip address 14.1.1.4 255.255.255.0
interface FastEthernet1/0
ip address 24.1.1.4 255.255.255.0
router ospf 110
router-id 4.4.4.4
network 4.4.4.0 0.0.0.255 area 0
network 14.1.1.0 0.0.0.255 area 0
network 24.1.1.0 0.0.0.255 area 0
router bgp 4
no synchronization
bgp router-id 4.4.4.4
neighbor 1.1.1.1 remote-as 4
neighbor 1.1.1.1 update-source Loopback0
neighbor 2.2.2.2 remote-as 4
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
4、默认选路
根据BGP选路原则第八条可以知道,R4到达3.3.3.0/24、33.33.33.0/24都是经过R2。
5、全部修改通告给IBGP邻居的路由的Local preference值
由前面可以R4到达3.3.3.0/24、33.33.33.0/24都是经过R2,我们通过修改Local preference值将R4到达3.3.3.0/24、33.33.33.0/24都是经过R1。
R4配置
router bgp 4
bgp default local-preference 125
6、部分修改通告给IBGP邻居的路由的Local preference值
R4到达3.3.3.0/24、33.33.33.0/24都是经过R2,我们通过修改Local preference值将R4到达3.3.3.0/24经过R2、达到33.33.33.0/24都是经过R1。
R4配置
ip prefix-list 1 seq 5 permit 33.33.33.0/24
no cdp log mismatch duplex
route-map L permit 10
match ip address prefix-list 1
set local-preference 125
route-map L permit 20
router bgp 4
neighbor 4.4.4.4 route-map L out